Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Security Level: All-users
    • Labels:
      None

      Description

      Fresh installation on wahmwebhosts.com. Have options to change PHP versions (currently 5.4), have access to local php.ini file for changes if needed. I extract the zip onto the server, access the directory from the web frontend to start installation. Requirements pass, database connection passes. Fails at 23% - Create default shop and languages

      this software does NOT notify the user of where it's failing or what it's failing on which makes more work for this Forge because it's so difficult to troubleshoot the installation. No errors are making it to my Apache error log.

      So far, since I have nothing else to go on, I've CHMOD all folders, recursively to 777, but that didn't change anything, but it's as expected since I wasn't receiving any permission denied errors in the error log of the web server. Is there a debug option for install or logging created during installation?

        Activity

        Show
        Damien Metzger added a comment - Fixed https://github.com/PrestaShop/PrestaShop/commit/c0c6c10bba393e64bb66362ed81ceb3885918f3e
        Hide
        Arnel Cee added a comment - - edited

        Hello Damien,

        I appreciate the work and the solution your provided. However, I'm having a problem implementing it. Do these modifications need to be made to the zipped installation files? Please pardon my ignorance. I was trying to implement the changes myself as per your link above, but the line numbers weren't matching up. I'm using Prestashop 1.5.4.1. I just wanted to make sure I'm doing this correctly. I tried making the changes to the installed files, then I also looked at the zipped installation files that I had downloaded, but I couldn't get the line numbers to match up. Is there any way to get the files already modified? Or are there further instructions that would clarify how the changes should be made that I'm missing?

        I was having problems editing the :

        DbMySQLi.php
        DbPDO.php
        MySQL.php

        As always, your help and patience is appreciated!

        Regards,
        Arnel C.
        InMotion Hosting Community Support Team

        Show
        Arnel Cee added a comment - - edited Hello Damien, I appreciate the work and the solution your provided. However, I'm having a problem implementing it. Do these modifications need to be made to the zipped installation files? Please pardon my ignorance. I was trying to implement the changes myself as per your link above, but the line numbers weren't matching up. I'm using Prestashop 1.5.4.1. I just wanted to make sure I'm doing this correctly. I tried making the changes to the installed files, then I also looked at the zipped installation files that I had downloaded, but I couldn't get the line numbers to match up. Is there any way to get the files already modified? Or are there further instructions that would clarify how the changes should be made that I'm missing? I was having problems editing the : DbMySQLi.php DbPDO.php MySQL.php As always, your help and patience is appreciated! Regards, Arnel C. InMotion Hosting Community Support Team
        Hide
        Damien Metzger added a comment -

        Hello,

        You can retrieve the files directly on our github repository:
        https://github.com/PrestaShop/PrestaShop/tree/development/classes/db

        Regards,

        Show
        Damien Metzger added a comment - Hello, You can retrieve the files directly on our github repository: https://github.com/PrestaShop/PrestaShop/tree/development/classes/db Regards,
        Hide
        hadi nurcahya added a comment -

        Implemented changes from github to all the files shown in this commit:

        https://github.com/PrestaShop/PrestaShop/commit/c0c6c10bba393e64bb66362ed81ceb3885918f3e

        Language.php
        DbMySQLi.php
        DbPDO.php
        MySQL.php
        Install.php

        Still same error at 23% 'Create default shop and languages'

        I am using United States / US/Central, also tried France, no luck.

        Please help.

        Thanks

        Show
        hadi nurcahya added a comment - Implemented changes from github to all the files shown in this commit: https://github.com/PrestaShop/PrestaShop/commit/c0c6c10bba393e64bb66362ed81ceb3885918f3e Language.php DbMySQLi.php DbPDO.php MySQL.php Install.php Still same error at 23% 'Create default shop and languages' I am using United States / US/Central, also tried France, no luck. Please help. Thanks
        Hide
        Michael added a comment -

        hi Guys

        I'm a total newbie and have had exactly this same problem but I have the answer to all your problems
        hopefully it works for you too! ...all praise goes to Usef from Easily servers UK for his valid assistance and technical knowledge ..

        go to the php ini file and change the following:

        delete the CH MOD File
        turn SAFE MODE off (default is on)

        re-upload the ini file to the server and voila

        kind regards
        Mike UK

        Show
        Michael added a comment - hi Guys I'm a total newbie and have had exactly this same problem but I have the answer to all your problems hopefully it works for you too! ...all praise goes to Usef from Easily servers UK for his valid assistance and technical knowledge .. go to the php ini file and change the following: delete the CH MOD File turn SAFE MODE off (default is on) re-upload the ini file to the server and voila kind regards Mike UK

          People

          • Assignee:
            Damien Metzger
            Reporter:
            Shawn Hanf
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: