Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Security Level: All-users
    • Labels:
      None

      Description

      Each "Group" in PrestaShop is attached to a particular Shop, cf the SQL table "ps_group_shop".

      With an up-to-date PrestaShop master branch from github, when I do a GET on /api/groups/1 I have :
      <prestashop>
      <group>
      <id>1</id>
      <reduction>0.00</reduction>
      <price_display_method>0</price_display_method>
      <show_prices>1</show_prices>
      <date_add>2013-03-15 09:48:46</date_add>
      <date_upd>2013-03-15 09:48:46</date_upd>
      <name>
      <language id="1" xlink:href="http://localhost/psmaster/api/languages/1">Visitor</language>
      <language id="5" xlink:href="http://localhost/psmaster/api/languages/5">Visiteur</language>
      </name>
      </group>
      </prestashop>

      As you can see, I don't have the info about the ID of the Shop to which this group is attached in the XML !

      We would like to have this information to do a proper implementation in the OpenERP-PrestaShop connector.

        Attachments

          Activity

            People

            • Assignee:
              rGaillard Rémi GAILLARD
              Reporter:
              sixela Alexis de Lattre
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support