Prestashop Core Application V1.5
  1. Prestashop Core Application V1.5
  2. PSCFV-7379

PrestaShop 1.5.3 An error occured during installation

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Security Level: All-users
    • Labels:
      None

      Description

      I download Prestashop 1.5.3, and try to install it in my new server host, for more then 10 times, when it's 75% of installation, I got the same error:
      Create settings.inc file
      Create database tables
      Create default shop and languages
      Populate database tables
      Configure shop information
      Install modules
      Install demonstration data

      An error occured during installation...

      The Server information is:
      Server information: Linux #1 SMP Wed Dec 19 07:05:20 UTC 2012 x86_64
      Server software version: Apache
      PHP version: 5.3.3
      Memory limit: 999M
      Max execution time: 0

      Database information:
      MySQL version: 5.1.66
      MySQL engine: InnoDB
      Tables prefix: ps_

      I have tried thes ways to fix it, but not ok:
      1) set 777 to web root folder;
      2) set Memory limit: 999M; Max execution time: 0;
      3) use Firefox, Google Chrome to install
      4) 'display_errors', 'on' , but no error info;

      I use Prestashop from 1.4.0, and Never meet this kind of problems, Could anyone knows what's the problems? Thanks a lot!

        Activity

        Hide
        GAO LINBO added a comment -

        Hi, I find in the error log, and it shows that:

        1) in HTML error: Internal Server Error. The server encountered an internal error or misconfiguration and was unable to complete your request.

        2) in suexec_log: [2013-01-18 22:02:21]: uid: (10000/10000) gid: (505/505) cmd: cgi_wrapper.

        3) no other error.

        How to fix it? Thank you!

        Show
        GAO LINBO added a comment - Hi, I find in the error log, and it shows that: 1) in HTML error: Internal Server Error. The server encountered an internal error or misconfiguration and was unable to complete your request. 2) in suexec_log: [2013-01-18 22:02:21] : uid: (10000/10000) gid: (505/505) cmd: cgi_wrapper. 3) no other error. How to fix it? Thank you!
        Hide
        Rémi GAILLARD added a comment -

        Hi Gao,

        Thank you for your bug report.
        Can you send to remi.gaillard@prestashop.com your FTP and MySQL credentials ? I will try the install by myself. Which default country have you choosen during the install ?

        Show
        Rémi GAILLARD added a comment - Hi Gao, Thank you for your bug report. Can you send to remi.gaillard@prestashop.com your FTP and MySQL credentials ? I will try the install by myself. Which default country have you choosen during the install ?
        Hide
        GAO LINBO added a comment -

        Hello, the error is fixed by changing the server setting:

        PHP support: Run PHP as "Apache module" instead of "FastCGI application".

        OK, It's finished. Thanks a lot!

        Show
        GAO LINBO added a comment - Hello, the error is fixed by changing the server setting: PHP support: Run PHP as "Apache module" instead of "FastCGI application". OK, It's finished. Thanks a lot!
        Hide
        Rémi GAILLARD added a comment -

        What is your hosting provider ?
        Can you still send to me the element ? In order to fix this issue for other people which is in the same case of you ?

        Show
        Rémi GAILLARD added a comment - What is your hosting provider ? Can you still send to me the element ? In order to fix this issue for other people which is in the same case of you ?
        Hide
        GAO LINBO added a comment -

        My hosting provider is 1and1.fr

        and the server plan is "Serveurs Dédiés: Serveur XL 6 (Linux, Plesk11 + CentOS 6.3).

        when buying a new Serveurs Dédiés, the php support is "FastCGI application" by default (before it was "Apache module"), so I met this problem for several days.

        Now it is clear that, this error was the php support of the new server.

        Show
        GAO LINBO added a comment - My hosting provider is 1and1.fr and the server plan is "Serveurs Dédiés: Serveur XL 6 (Linux, Plesk11 + CentOS 6.3). when buying a new Serveurs Dédiés, the php support is "FastCGI application" by default (before it was "Apache module"), so I met this problem for several days. Now it is clear that, this error was the php support of the new server.
        Hide
        danielle added a comment -

        Hi I encounter the same error with v1.5.4 with the same provider but not on a dedicated server though I have ssh rights. What is possible ? As I am new to php, please be really explicit
        Locally I did n't have any problems.
        Thanks

        Show
        danielle added a comment - Hi I encounter the same error with v1.5.4 with the same provider but not on a dedicated server though I have ssh rights. What is possible ? As I am new to php, please be really explicit Locally I did n't have any problems. Thanks
        Hide
        GAO LINBO added a comment -

        Hi, Could you give a detailed information of your server?

        Show
        GAO LINBO added a comment - Hi, Could you give a detailed information of your server?

          People

          • Assignee:
            Rémi GAILLARD
            Reporter:
            GAO LINBO
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: