Uploaded image for project: 'PrestaShop 1.7'
  1. PrestaShop 1.7
  2. BOOM-4228

CLONE - Webeservice: tracking link is not added to the email

    Details

    • Type: Bug
    • Status: To be specified
    • Priority: Standard
    • Resolution: Unresolved
    • Affects Version/s: 1.7.2.4
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      I am using the webservice to set the tracking number for orders, and change their status to shipped. To set the tracking number I do the following:

      I update the order: set shipping_number
      I update the order_carrier: set tracking_number (this may be redundant now, I noticed that in code, when updating shipping_number, tracking_number is also updated).
      I add a new order history: status Shipped

      After this I get the shipping email which contains the name of the customer, the number of the order, but no tracking link.
      If I go to this order in the back office, then I can find the tracking number.
      If I click on the link, then it takes me to the tracking page.

      If I set the tracking number in the back office, and change status to shipped, then the tracking link is displayed correctly in the email.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pablo.borowicz Pablo Borowicz
                Reporter:
                salma.moakhar Salma
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: